AssetCacheManagerUtil(8) System Manager's Manual AssetCacheManagerUtil(8)
AssetCacheManagerUtil – control the macOS Content Cache
AssetCacheManagerUtil [-a|--all] [-j|--json] [-l|--linger] command
AssetCacheManagerUtil controls the macOS Content Cache.
AssetCacheManagerUtil must be run by root except as noted below. The
Show all events, not just the end result of the specified command.
Print results in machine-parseable JSON format to stdout.
Linger after completing command, to show other events.
The commands are:
Activates the content cache. Content caching is deactivated by
default. After you activate content caching, restart devices on
your network to take advantage of content caching immediately.
Devices on your network will discover this content cache over time.
Devices that are restarted will use this content cache immediately.
Deactivates the content cache.
Reports the content cache's activation status. Does not require
Reports whether the content cache is eligible for activation. Does
not require root.
Flushes the content cache.
Flushes all personal (iCloud) content from the content cache.
Flushes all shared (non-iCloud) content from the content cache.
status Reports the content cache's status. Does not require root.
Reports the content cache's settings. Does not require root.
Forces the content cache to reload its settings.
Moves the cache to path. The path must end with
/Library/Application Support/Apple/AssetCache/Data. The contents
of path are deleted and replaced with the cache.
absorbCacheFrom path read-only|and-destroy
Imports the cache from path. The path must end with either
/Library/Application Support/Apple/AssetCache/Data or
/Library/Server/Caching/Data. If the last argument is read-only
the cache at path is not modified, otherwise it is emptied. This
command only starts the absorption, which proceeds and finishes in
the background. Use the log(1) command to view progress, for
example: log show --predicate 'subsystem == "com.apple.AssetCache"'
--style compact --last 5m
System Preferences > Sharing > Content Caching, AssetCache(8),
macOS 10/24/16 macOS