HOSTINFO(8) System Manager's Manual HOSTINFO(8)
hostinfo – host information
The hostinfo command displays information about the host system on which
the command is executing. The output includes a kernel version
description, processor configuration data, available physical memory, and
various scheduling statistics.
There are no options.
Mach kernel version:
The version string compiled into the kernel executing on the host
The maximum possible processors for which the kernel is configured,
followed by the number of physical and logical processors available.
Note: on Intel architectures, physical processors are referred to as
cores, and logical processors are referred to as hardware threads;
there may be multiple logical processors per core and multiple cores
per processor package. This command does not report the number of
The host's processor type and subtype.
A list of active processors on the host system. Active processors
are members of a processor set and are ready to dispatch threads. On
a single processor system, the active processor, is processor 0.
Primary memory available:
The amount of physical memory that is configured for use on the host
Default processor set:
Displays the number of tasks currently assigned to the host processor
set, the number of threads currently assigned to the host processor
set, and the number of processors included in the host processor set.
Measures the average number of threads in the run queue.
A variant of the load average which measures the processing resources
available to a new thread. Mach factor is based on the number of
CPUs divided by (1 + the number of runnablethreads) or the number of
CPUs minus the number of runnable threads when the number of runnable
threads is less than the number of CPUs. The closer the Mach factor
value is to zero, the higher the load. On an idle system with a
fixed number of active processors, the mach factor will be equal to
the number of CPUs.
macOS October 30, 2003 macOS